Cisco 2960-X Stack Randomly Dropping Traffic

Symptom: Out of my 50+ 2960X switches, I have a stack of 6 that will randomly drop all traffic on random ports on the access VLAN for about 60 seconds. When the issue happens, the port shows up/up on the switch and the computer, but all traffic is dropped, including pings from the computer to the vlan interface on the switch. This does not happen to all the ports, and it does not consistently happen to the same ports. It also does not happen for a single vlan, it happens to whatever vlan is the access vlan on the port. If a phone is connected to the port, the phone is not affected (can still make calls)! Since it is random, and there are no logs or interface errors, it makes this very difficult to troubleshoot for me and TAC. Curious is anyone has seen something like this before. Leaning towards some sort of hardware problem.

 

Switch: WS-C2960X-48FPD-L
IOS version: 15.2(2)E6
Number of switches in stack: 6

Interface configuration:
switchport access vlan 10
switchport mode access
switchport voice vlan 20
switchport port-security maximum 6
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security
load-interval 30
power inline police action log
no power efficient-ethernet
srr-queue bandwidth share 1 30 35 5
priority-queue out
ipv6 nd raguard attach-policy RA-BLOCK
ipv6 dhcp guard attach-policy DHCP-CLIENT
no snmp trap link-status
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
storm-control broadcast level pps 1k 500
storm-control action shutdown
storm-control action trap
spanning-tree portfast
service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY
ip dhcp snooping limit rate 100

 

Troubleshooting:
Looked at all logs
Upgraded to gold star release
Restarted stack
Changed stack masters
Verify spanning-tree is not having issues
Removed 7th switch from stack (it works fine by itself)

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: